[Netkit.users] Resize Filesystem problem

Bertolucci Nicola nicola.bertolucci a gmail.com
Lun 15 Gen 2007 15:26:54 CET


Hi all
I tried  to resize the filesystem like I read in your thread on December.

*# Replace "newsize" by the size you want dd if=/dev/zero of=
*>>* $NETKIT_HOME/fs/netkit-fs-F2.2 bs=1 count=1 seek="newsize"
*>>* conv=notrunc
*>>*
*>>* # Attach the filesystem to a loop device % losetup -o 16384
*>>* /dev/loop0 $NETKIT_HOME/fs/netkit-fs-F2.2
*>>*
*>>* # Resize the filesystem
*>>* % resize2fs -p /dev/loop0
*>>*
*>>* # Check if the filesystem is consistent
*>>* % e2fsck -f /dev/loop0
*>>*
*>>* # Detach from loop device
*>>* % losetup -d /dev/loop0*


where in new size i put 4G.
Everythings is ok,i don't have any errors,and the filesystem size is 4,1 G
as i wanted.
But when i try to start virtual machine with command vstart pc1 --eth0=1 ,in
the shell of a virtual machine i have:

INIT: version 2.86 booting
Activating swap.
Checking root file system...
fsck 1.37 (21-Mar-2005)
/dev/ubd/disc0/part1: The filesystem size (according to the superblock) is
1048572 blocks
The physical size of the device is 153596 blocks
Either the superblock or the partition table is likely to be corrupt!


/dev/ubd/disc0/part1: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
        (i.e., without -a or -p options)

fsck failed.  Please repair manually and reboot.  Please note
that the root file system is currently mounted read-only.  To
remount it read-write:

   # mount -n -o remount,rw /

CONTROL-D will exit from this shell and REBOOT the system.

Give root password for maintenance
(or type Control-D to continue):

At this time i tried to remount the fs,but nothing to do,when i restart the
virtual machine i receive the same error.
What can i do to resolv my problem?
Thanks
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: http://list.dia.uniroma3.it/mailman/private/netkit.users/attachments/20070115/fc7a10a2/attachment.html


Maggiori informazioni sulla lista Netkit.users