[Netkit.users] Two small ltest bugs/problems

Adrian van Dongen adrianvandongen at gmail.com
Thu Mar 5 11:08:30 CET 2009

Dear Massimo,

First, thanks for the last email. I am a little swamped at the moment but as
soon as i have some spare time I will see how far I cant get :)  The reason
I am emailing again is because I found 2 small bugs when using ltest. One I
could fix myself the other I need some help with.

The first is a small path problem in /etc/init.d/netkit-test-phase. When
running ltest the vm's give an error when trying to shut down:

*Running lab test, please wait... [/etc/init.d/netkit-test-phase: line 87:
/sbin/ip: No such file or directory*

This was simpel to fix, I ran a single vm and located the the ip command and
it turned out to be in /usr/sbin/ instead of /sbin/. So i mounted/chrooted
into the filesystem and changed that in the init script, problem solved.

The reason I was looking into the ltest because in my setup the vm's do not
stop eventhought i waited pretty long. I end up using lhalt/lcrash to stop
the vm's. I checked netkit-test-phase and as I understand it the process
should sleep 30 seconds and than end. Any idea why this is not happening (I
am running Ubuntu 8.10)


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://list.dia.uniroma3.it/pipermail/netkit.users/attachments/20090305/a1f8fb31/attachment.htm 

More information about the Netkit.users mailing list