[Netkit.users] Two small ltest bugs/problems

Massimo Rimondini rimondin at dia.uniroma3.it
Fri Mar 6 11:05:35 CET 2009

Dear Adrian,

> This was simpel to fix, I ran a single vm and located the the ip command and
> it turned out to be in /usr/sbin/ instead of /sbin/. So i mounted/chrooted
> into the filesystem and changed that in the init script, problem solved.

Ok. Thank you very much for pointing this out.

> The reason I was looking into the ltest because in my setup the vm's do not
> stop eventhought i waited pretty long. I end up using lhalt/lcrash to stop
> the vm's. I checked netkit-test-phase and as I understand it the process
> should sleep 30 seconds and than end. Any idea why this is not happening (I
> am running Ubuntu 8.10)

Yes, worse luck. It's a bug in the ltest scripts. The shutdown command
is expected to come from outside the virtual machines, but it never
does. The reason why this managed to the release is that our
development environment sends that command independently of the

I think the most simple fix for you is to alter the virtual machine
filesystem replacing the last line of /etc/init.d/netkit-test-phase
(the one with the "while") with something like "/sbin/halt".

Sorry for these inconveniences. We have put these bugs into our fix queue.

Thank you very much for the report and regards,

More information about the Netkit.users mailing list