[Netkit.users] Problem with libc upgrading

Emanuele Corso ritualrp a gmail.com
Mer 20 Giu 2007 23:28:53 CEST


Thank you, the 3.0a filesystem solved my problem

Emanuele



2007/6/19, Luca Troiani <luca.troiani a tin.it>:
>
>  If I'm not wrong, that filesystem already had what you need.
>
>
> ----- Original Message -----
> *From:* Emanuele Corso <ritualrp a gmail.com>
> *To:* netkit.users a list.dia.uniroma3.it
> *Sent:* Tuesday, June 19, 2007 6:51 PM
> *Subject:* Re: [Netkit.users] Problem with libc upgrading
>
> The problem is that I need the upgraded version of libc to resolve the
> dependencies of the library libjpcap.so
> This is the output of "ldd libjpcap.so":
>
> libjpcap.so: /lib/libc.so.6: version `GLIBC_2.4' not found (required by
> libjpcap.so)
>         linux-gate.so.1 =>  (0xffffe000)
>         libpcap.so.0.8 => /usr/lib/libpcap.so.0.8 (0x40024000)
>         libc.so.6 => /lib/libc.so.6 (0x4004e000)
>         /lib/ld-linux.so.2 (0x15555000)
>
>
>
> 2007/6/19, Luca Troiani <luca.troiani a gmail.com>:
> >
> >  Dear Emanuele,
> > I had the same problem installing a new version of gcc, because it
> > needed upgraded version of libc.
> > I discovered, after lots of trouble, that the packet I downloaded from
> > the repository was wrong (it had a bug or something similar).
> > There is only one solution (I know): use a Netkit filesystem already
> > upgraded.
> >
> > This link should resolve your problem:
> > http://giga.dia.uniroma3.it/~rimondin/netkit-fs-F3.0a.bz2<http://giga.dia.uniroma3.it/%7Erimondin/netkit-fs-F3.0a.bz2>
> >
> > Regards,
> >
> > Luca
> >
> > ----- Original Message -----
> > *From:* Emanuele Corso <ritualrp a gmail.com>
> > *To:* netkit. users <netkit.users a list.dia.uniroma3.it>
> > *Sent:* Tuesday, June 19, 2007 12:58 AM
> > *Subject:* [Netkit.users] Problem with libc upgrading
> >
> >
> > I need a libc version >= 2.5
> > So I added to sources.list the line "deb http://ftp.us.debian.org/debian
> > unstable main contrib non-free"
> > and did a "apt-get update" and a "apt-get install libc6"
> >
> > apt-get is going to upgrade libc6-dev and locales, and remove tzdata
> > but the update fails
> >
> > This is the output:
> >
> > Preparing to replace libc6 2.3.6.ds1-13 (using
> > .../libc6_2.5-9+b1_i386.deb) ...
> > Unpacking replacement libc6 ...
> > cannot set up thread-local storage: set_thread_area failed when setting
> > up thread-local storage
> >
> > dpkg: warning - old post-removal script returned error exit status 127
> > dpkg - trying script from the new package instead ...
> > cannot set up thread-local storage: set_thread_area failed when setting
> > up thread-local storage
> >
> > dpkg: error processing /var/cache/apt/archives/libc6_2.5-9+b1_i386.deb
> > (--unpack):
> >  subprocess new post-removal script returned error exit status 127
> > cannot set up thread-local storage: set_thread_area failed when setting
> > up thread-local storage
> >
> > dpkg: error while cleaning up:
> >  subprocess pre-installation script returned error exit status 127
> > Errors were encountered while processing:
> >  /var/cache/apt/archives/libc6_2.5-9+b1_i386.deb
> > E: Sub-process /usr/bin/dpkg returned an error code (1)
> >
> >
> > Anyone knows how to do this upgrade?
> > Thanks
> >
> > Emanuele Corso
> >
> > ------------------------------
> >
> > _______________________________________________
> > Netkit.users mailing list
> > Netkit.users a list.dia.uniroma3.it
> > http://list.dia.uniroma3.it/mailman/listinfo/netkit.users
> >
> >
>  ------------------------------
>
> _______________________________________________
> Netkit.users mailing list
> Netkit.users a list.dia.uniroma3.it
> http://list.dia.uniroma3.it/mailman/listinfo/netkit.users
>
>
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: http://list.dia.uniroma3.it/mailman/private/netkit.users/attachments/20070620/7d93f632/attachment.html


Maggiori informazioni sulla lista Netkit.users