[Netkit.users] Problem with libc upgrading

Emanuele Corso ritualrp a gmail.com
Mar 19 Giu 2007 00:58:19 CEST


I need a libc version >= 2.5
So I added to sources.list the line "deb
http://ftp.us.debian.org/debianunstable main contrib non-free"
and did a "apt-get update" and a "apt-get install libc6"

apt-get is going to upgrade libc6-dev and locales, and remove tzdata
but the update fails

This is the output:

Preparing to replace libc6 2.3.6.ds1-13 (using .../libc6_2.5-9+b1_i386.deb)
...
Unpacking replacement libc6 ...
cannot set up thread-local storage: set_thread_area failed when setting up
thread-local storage

dpkg: warning - old post-removal script returned error exit status 127
dpkg - trying script from the new package instead ...
cannot set up thread-local storage: set_thread_area failed when setting up
thread-local storage

dpkg: error processing /var/cache/apt/archives/libc6_2.5-9+b1_i386.deb
(--unpack):
 subprocess new post-removal script returned error exit status 127
cannot set up thread-local storage: set_thread_area failed when setting up
thread-local storage

dpkg: error while cleaning up:
 subprocess pre-installation script returned error exit status 127
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.5-9+b1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Anyone knows how to do this upgrade?
Thanks

Emanuele Corso
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: http://list.dia.uniroma3.it/mailman/private/netkit.users/attachments/20070619/dba980fd/attachment.htm


Maggiori informazioni sulla lista Netkit.users