[Netkit.users] problem: install mysql-server

Massimo Rimondini rimondin at dia.uniroma3.it
Mon Nov 12 16:54:17 CET 2012

Dear Mr. Brugaletta,

actually, installation of the current mysql-server package has so many dependencies that significant critical portions of the filesystem image are updated as consequence, thus likely breaking some other Netkit functionalities. This includes, for example, the sysc-rc package governing system services. I can confirm the problem but, rather than suggesting a way through (I could solve that error, but several other dependencies are pulled in immediately after, resulting in an almost complete system upgrade), I can suggest a much easier and hopefully effective way around.

Starting from a clean filesystem image (i.e., one where you haven't yet attempted this unsuccessful installation), change file /etc/apt/sources.list and turn line 25 (it's the only uncommented line) into the following:
> deb http://ftp.it.debian.org/debian/ squeeze main contrib non-free

As you can see, the distribution name has been changed from "unstable" to "squeeze" to stick on a release of the mysql-server package that is more in line with the rest of the system.
At this point you should be able to successfully install the package.


On 11/12/2012 11:48 AM, Nunzio Brugaletta wrote:
> Hello,
> I'm itc teacher and now I use netkit for networking teaching. I need to add some packages: mysql, php.
> I have tried so long to install mysql-server (apt-get update && apt-get install mysql-server in vm or mount -o loop fs) but I read always this message:
> dpkg: error processing sysv-rc (--configure):
>  subprocess installed post-installation script returned error exit status 1
> Errors were encountered while processing:
>  sysv-rc
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> I run netkit under Ubuntu 12.04.
> How can I do to install these packages?
> Thanks.
> Regards

More information about the Netkit.users mailing list