[Netkit.users] Too many netkit machines?

Gareth Lapworth glapworth at dmu.ac.uk
Mon Mar 21 15:49:33 CET 2011

Dear Massimo,

Thank you for getting back in touch.  I discovered my problem a few
hours after sending my email but I was pushed for time due to a tight
deadline.  The problem seemed to be that I ran out of space in
/dev/shm.  I remounted /dev/shm by typing sudo mount -o
remount,size=4G /dev/shm and I was able to run the entire lab.

It is probably useful for me to mention that there are lots of netkit
instances running on this host machine, and a large proportion of them
have been given around 256Mb RAM so they can usefully run various
scripts and act as apart of a group in a scenario that I have been
planning for some of my students.

I did have some time this morning to try something outrageous - I
created a 40Gb file in the root directory of my host machine, and
mounted it as /dev/shm.  It shows up as a mounted filesystem, but it
isn't really used.  To be honest, I didn't think it would be, but it
was worth a try.

Thanks again for your help.

All the best,

On 18 March 2011 13:29, Massimo Rimondini <rimondin at dia.uniroma3.it> wrote:
> Dear Gareth,
> the issue you are reporting seems quite strange. There should be no hard
> limit apart from computational resources. On the other hand, I could only
> just start 45 virtual machines (with a "factory configuration") on a Core 2
> Quad with 4GB of RAM without any problems.
> Here is a first checklist of things that come into my mind:
> - disable exec-shield (sysctl -w kernel.exec-shield=0);
> - check for messages from the host kernel; some actions (e.g. out-of-memory
> killing) are undertaken without the user being notified;
> - check how many running processes/threads you have (unlikely to happen, but
> you might be running out of PIDs);
> - check that you can launch multiple (by "multiple" I mean "really many")
> instances of the terminal emulator you are using; a crashing terminal
> emulator could be another cause for apparently inexplicable virtual machine
> aborts.
> Regards,
> Massimo.
> On 03/16/2011 09:16 PM, Gareth Lapworth wrote:
> Dear All,
> I have just joined the list, so I do apologise if this has been asked
> before - I have also searched the website, and looked through the
> mailing list archives but I didn't seem to find an answer to my
> problem.
> I am in the process of building a netkit lab.  I have 37 of my
> machines currently running but it seems that I have hit a wall and I
> am unable to launch any more.  When I attempt to launch a further
> machine, an xterm executes and quickly dies.  I ran the command
> vstart vm --verbose --con0=this to see if I could catch the error
> message before it disappeared,  The following data was displayed:
> ============= Starting virtual machine "vm" =============
>    Kernel:     /opt/netkit/kernel/netkit-kernel
>    Modules:    /opt/netkit/kernel/modules
>    Memory:     32 MB
>    Model fs:   /opt/netkit/fs/netkit-fs
>    Filesystem: /home/glapworth/labs/ctec3427_cw2/nw-c/vm.disk (new)
>    Hostfs at:  /home/glapworth
> Running ==> /opt/netkit/kernel/netkit-kernel
> modules=/opt/netkit/kernel/modules name=vm title=vm umid=vm mem=36M
> ubd0=/home/glapworth/labs/ctec3427_cw2/nw-c/vm.disk,/opt/netkit/fs/netkit-fs
> root=98:1 uml_dir=/home/glapworth/.
> netkit/mconsole
> hosthome=/home/glapworth con0=fd:0,fd:1 con1=null SELINUX_INIT=0
> Locating the bottom of the address space ... 0x10000
> Locating the top of the address space ... 0xc0000000
> Core dump limits :
> 	soft - 0
> 	hard - NONE
> Checking that ptrace can change system call numbers...OK
> Checking syscall emulation patch for ptrace...OK
> Checking advanced syscall emulation patch for ptrace...OK
> Checking for tmpfs mount on /dev/shm...OK
> Checking PROT_EXEC mmap in /dev/shm/...OK
> Checking for the skas3 patch in the host:
>   - /proc/mm...not found: No such file or directory
>   - PTRACE_FAULTINFO...not found
>   - PTRACE_LDT...not found
> UML running in SKAS0 mode
> Adding 2617344 bytes to physical memory to account for exec-shield gap
> Terminated
> I can't see anything in this output that corresponds to a problem
> other than the word "Terminated". The machine I am running on is a
> quad core Xeon with 6Gb RAM running Ubuntu 10.04.  My system shows
> that I have only used 647Mb RAM at the moment and therefore I should
> have adequate to continue.  My CPU is happily running at 5% usage on
> average so this shouldn't be too taxing on the hardware.
> I've checked my file limits and I am not getting any too many open
> files errors.  Any ideas or help would be greatly appreciated.
> Thanks in advance.
> All the best,
> Gareth
> _______________________________________________
> Netkit.users mailing list
> Netkit.users at list.dia.uniroma3.it
> http://list.dia.uniroma3.it/mailman/listinfo/netkit.users
> _______________________________________________
> Netkit.users mailing list
> Netkit.users at list.dia.uniroma3.it
> http://list.dia.uniroma3.it/mailman/listinfo/netkit.users

More information about the Netkit.users mailing list