[Netkit.users] version GLIBC_2.0 not defined

Massimo Rimondini rimondin at dia.uniroma3.it
Tue Jan 25 10:06:48 CET 2011

Dear Adrian and Luca,

I too was guessing the problem to be taking place under Ubuntu 10.10,
but I would have expected a slightly different kind of error:

> ../sysdeps/unix/sysv/linux/getpagesize.c:32: __getpagesize: Assertion
> `_rtld_global_ro._dl_pagesize != 0' failed.

However, if this is the case, there is a better workaround than
downgrading :-)
You just need to install the uml-utilities package from the standard
Ubuntu repository. After that, the problem should be solved. If it is
not, you may have to tweak your PATH environment variable to consider
system-wide binary locations (i.e., /bin/, /usr/bin/, etc.) before
Netkit's, or it may simply be a matter of flushing the shell's command
hash table ("hash -r" or simply close the shell and open a new one).

I'm still unsure about whether this can solve your problem, but it is
worth trying.


On 01/25/2011 05:35 AM, Adrian van Dongen wrote:
> Hi Luca,
> You are probably running Ubuntu 10.10, am i right ? A colleague of
> mine tried running Netkit on Ubuntu 10.10 and got the same error. He
> just downgraded tot 10.04 and it just worked fine (has been working
> fine on 10.04 for a while now). I know its not a real solution but if
> you really need to get going that is the fastest way.
> Ubuntu 10.10 probably has other GLIB/Libc library's and netkit would
> need to be compiled again to meet the new library's. But that is just
> my wild guess so Massimo please correct me if i am wrong :)
> Regards,
> Adrian.
> On Tue, Jan 25, 2011 at 12:01 AM, Luca Dionisi <luca.dionisi a gmail.com
> <mailto:luca.dionisi a gmail.com>> wrote:
>     Hi all,
>     I installed netkit some months ago. Version numbers are the latest.
>     I used it many times, also with tap interface, successfully.
>     Today I tried "vstart pc1 --eth0=tap,," and got
>     this error:
>     Setting up tunnel...                    tunctl: relocation error:
>     /lib/libnss_compat.so.2: symbol strcmp, version GLIBC_2.0 not defined
>     in file libc.so.6 with link time reference
>     I can launch a normal guest. Only when using tunctl the problem
>     arises.
>     I cannot tell when exactly the problem started. I did not use
>     "tap" recently.
>     What's going on?
>     --Luca
>     _______________________________________________
>     Netkit.users mailing list
>     Netkit.users a list.dia.uniroma3.it
>     <mailto:Netkit.users a list.dia.uniroma3.it>
>     http://list.dia.uniroma3.it/mailman/listinfo/netkit.users
> _______________________________________________
> Netkit.users mailing list
> Netkit.users a list.dia.uniroma3.it
> http://list.dia.uniroma3.it/mailman/listinfo/netkit.users
-------------- parte successiva --------------
Un allegato HTML ? stato rimosso...
URL: <http://list.dia.uniroma3.it/pipermail/netkit.users/attachments/20110125/1e8028bf/attachment.html>

More information about the Netkit.users mailing list