[Netkit.users] version GLIBC_2.0 not defined

Adrian van Dongen adrianvandongen at gmail.com
Tue Jan 25 05:35:04 CET 2011

Hi Luca,

You are probably running Ubuntu 10.10, am i right ? A colleague of mine
tried running Netkit on Ubuntu 10.10 and got the same error. He just
downgraded tot 10.04 and it just worked fine (has been working fine on 10.04
for a while now). I know its not a real solution but if you really need to
get going that is the fastest way.

Ubuntu 10.10 probably has other GLIB/Libc library's and netkit would need to
be compiled again to meet the new library's. But that is just my wild guess
so Massimo please correct me if i am wrong :)



On Tue, Jan 25, 2011 at 12:01 AM, Luca Dionisi <luca.dionisi at gmail.com>wrote:

> Hi all,
> I installed netkit some months ago. Version numbers are the latest.
> I used it many times, also with tap interface, successfully.
> Today I tried "vstart pc1 --eth0=tap,," and got this error:
> Setting up tunnel...                    tunctl: relocation error:
> /lib/libnss_compat.so.2: symbol strcmp, version GLIBC_2.0 not defined
> in file libc.so.6 with link time reference
> I can launch a normal guest. Only when using tunctl the problem arises.
> I cannot tell when exactly the problem started. I did not use "tap"
> recently.
> What's going on?
> --Luca
> _______________________________________________
> Netkit.users mailing list
> Netkit.users at list.dia.uniroma3.it
> http://list.dia.uniroma3.it/mailman/listinfo/netkit.users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.dia.uniroma3.it/pipermail/netkit.users/attachments/20110125/e95eb73c/attachment.html>

More information about the Netkit.users mailing list