[Netkit.users] Problem when trying to create my own fs

Julien Iguchi-Cartigny julien.cartigny at unilim.fr
Sat Aug 7 13:59:45 CEST 2010

Dear Massimo,

I've tried today to build my own FS but i've a new error:

root at kartoch-laptop:/home/kartoch/opt/netkit/fs# make -f Makefile.devel
\e[1m\e[33m======= Downloading base packages... =====\e[0m
I: Retrieving Release
I: Retrieving Packages
I: Validating Packages
I: Resolving dependencies of required packages...
I: Resolving dependencies of base packages...
I: Found additional required dependencies: insserv libbz2-1.0 libdb4.8
I: Found additional base dependencies: libnfnetlink0 libsqlite3-0 libudev0
I: Checking component main on http://ftp.fr.debian.org/debian...
E: Couldn't find these debs: libept0
make: *** [debian-base-packages-sid-i386.tgz] Error 1

I've tried the italian and french debian mirrors but the problem is
still here. Have you any idea how to resolve it ?



On 05/31/2010 11:09 AM, Massimo Rimondini wrote:
> Dear Julien,
> mmm... the fact that the package has been downloaded seems to suggest
> that the apt system was already going to install it to satisfy
> dependencies. And, in fact, the package is listed in the log which you
> have sent me some time ago.
> I would suggest doing the following:
> 1) Since lots of packages and dependencies have likely been updated in
> the meantime, you may try to build again from scratch and hope that the
> error has just gone away (we too have experienced this sometime...). I
> would really give this a try.
> 2) If you really want to force installation, you can mount the partially
> built filesystem image and then run a command like "sudo chroot
> mounted_fs/var/cache/apt/archives/libbz2-1.0_1.0.5-4_i386.deb dpkg -i
> /var/cache/apt/archives/libbz2-1.0_1.0.5-4_i386.deb". In case the
> installation still fails, you may attempt to simply decompress the files
> inside the archive: "sudo chroot
> mounted_fs/var/cache/apt/archives/libbz2-1.0_1.0.5-4_i386.deb dpkg-deb
> -x /var/cache/apt/archives/libbz2-1.0_1.0.5-4_i386.deb /"
> Regards,
> Massimo.
> On 05/29/2010 01:53 PM, Julien Iguchi-Cartigny wrote:
>> Hello Massimo,
>> [...snip...]
>>> What I can suggest for the moment is to attempt to manually download and
>>> install the .deb file for libbz2-1.0, then try again to continue with the
>>> filesystem build.
>> How do you do this ? The libbz2 is downloaded:
>> mounted_fs/var/cache/apt/archives/libbz2-1.0_1.0.5-4_i386.deb
>> how can i manually install it during the image building process ?
>> Thank you.
>> Cheers,
>> Julien.
>> _______________________________________________
>> Netkit.users mailing list
>> Netkit.users at list.dia.uniroma3.it
>> http://list.dia.uniroma3.it/mailman/listinfo/netkit.users
> _______________________________________________
> Netkit.users mailing list
> Netkit.users at list.dia.uniroma3.it
> http://list.dia.uniroma3.it/mailman/listinfo/netkit.users

-------------- next part --------------
A non-text attachment was scrubbed...
Name: julien_cartigny.vcf
Type: text/x-vcard
Size: 328 bytes
Desc: not available
Url : http://list.dia.uniroma3.it/pipermail/netkit.users/attachments/20100807/c3b50115/attachment.vcf 

More information about the Netkit.users mailing list