[Netkit.users] How do I create a disk image to use with netkit?

Massimo Rimondini rimondin at dia.uniroma3.it
Mon Sep 7 17:04:35 CEST 2009

Dear Luca,

in the second case, try passing "--append=root=98:1" as option to vstart.

For a step-by-step resize procedure, I suggest you have a look at this
post, if you haven't already:


Luca Dionisi wrote:
> Hi all
> I need to instantiate a vm in netkit with more space on disk. The
> default has 1 GB.
> How do I create a disk image to use with netkit?
> The automated procedure (make -f Makefile.devel) is not working for me.
> I'd be really ok with a bigger disk with the same content of my
> current one. So I tried and created from scratch (dd) a disk image,
> created a partition, an ext3 fs on it, mounted it, and I copied the
> content of the original image.
> But when I launch vstart I got some strange behaviour.
> When I try:
>    vstart vm1 --verbose --con0=this
> results:
>   Creating "/home/luca/netkit_stuff/netsukuku/vm1.disk" as COW file
> for "/home/luca/netkit/fs/netkit-fs"
>    ubda: ubda1
>   VFS: Mounted root (ext2 filesystem) readonly.
> Whilst when I try:
>    vstart vm2 --verbose --con0=this -m /home/luca/netkit/fs/my-own-fs
> results:
>   Creating "/home/luca/netkit_stuff/netsukuku/vm2.disk" as COW file
> for "/home/luca/netkit/fs/my-own-fs"
>    ubda: ubda1
>   List of all partitions:
>   6200    1048576 ubda driver: uml-blkdev
>     6201    1048540 ubda1
>   No filesystem could mount root, tried:  ext3 ext2 cramfs romfs
>   Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(98,0)
> ------------------------------------------------------------------------
> _______________________________________________
> Netkit.users mailing list
> Netkit.users a list.dia.uniroma3.it
> http://list.dia.uniroma3.it/mailman/listinfo/netkit.users
-------------- parte successiva --------------
Un allegato HTML ? stato rimosso...
URL: http://list.dia.uniroma3.it/pipermail/netkit.users/attachments/20090907/4091968f/attachment.htm 

More information about the Netkit.users mailing list