[Netkit.users] Tap problem in netkit [SOLVED]

Massimo Rimondini rimondin at dia.uniroma3.it
Tue Mar 17 15:26:29 CET 2009

Dear Silvio,
> ifconfig nk_tap_silvio and all is ok! (Is this can be a
> bug in netkit or in my machine? What do you think?)

Interesting. This might depend on being a duplicate of your
host interface's address. But in this case, the virtual machine should
not start up at all, and you would get the same error even when manually
assigning the address. On the other hand, my (host) kernel does not seem
to bother if a tap device is assigned the same address as an Ethernet
Does vstart return any errors soon after you type the root password?
Could you try again after having run "vclean --clean-all"?

> The last help: how II use the tap option in lab.conf? My doubts about
> tap interfaces isn't clear in netkit wiki :)

This is clarified in the FAQs, Q06:

Essentially, you can put in your lab.conf the same tap option that you
passed to vstart. For example:

> Sorry for many and many questions :)))

Don't worry :-)


More information about the Netkit.users mailing list