[Netkit.users] Interface problem.-

Massimo Rimondini rimondin a dia.uniroma3.it
Mar 10 Gen 2006 10:26:06 CET


Hi Miguel,

you seem to have duplicate IP addresses in your configuration. In fact, 
195.11.14.5 is assigned to both vrouter1's tap interface and to pc1 (or 
pc2).

When you configure a tap interface, you have to specify two IP addresses:
- The "tap" address, which is the address of a fictitious network 
interface on the real host (you can even see it by using ifconfig on the 
real host). This interface serves as a connection point between vrouter1 
and the real network. Since this is the address of a new network 
interface, it cannot overlap with other existing addresses.
- The "guest" address, which is the address of a network interface 
showing up inside the virtual machine (vrouter1).

Uniqueness of IP addresses should however still be guaranteed.

I suggest to remove this problem before further analyzing the issue.

Regards,
Massimo.

Miguel Angel Ruiz wrote:

>  Hi Fabio,
>
>  
>
>  I have two problems;
>
>  
>
>  
>
>  
>
>     First: 
> _____________________________________________________________________________
>
>  
>
> *Pc1(real host)*----------------------*Pc2(real host)*
>
>                                                                  
> |------Vrouter1------Vrouter2
>
>  
>
>  
>
> -         First, profit that pingueen both between realhosts.
>
>             [root Pc1]#ping 195.11.14.1 .....ok.-
>
> [root Pc1]#ping 195.11.14.5 .....ok.-
>
> [root Pc2]#ping 195.11.14.5 .....ok.-
>
> [root Pc2]#ping 195.11.14.1 .....ok.-
>
>  
>
>  [root Pc2]#*vstart vrouter1 -eth0=tap,195.11.14.5,195.11.14.9 -eth1=A 
> -new*
>
> that it creates vrouter1, but,....
>
> [vrouter1]# ping 195.11.14.5   .....fail.-
>
> [root Pc2]# ping 195.11.14.9   .....fail.-
>
> [vrouter1]#*route -n *
>
>      Kernel ip routing table
>
> Destination     Gateway       Genmask         Flags      Metric      
> Ref     Use     Iface
>
> 195.11.14.0     0.0.0.0         255.255.255.0   U           0   
>             0       0          eth0
>
>     0.0.0.0        195.11.14.5    0.0.0.0              UG       
> 0               0        0         eth0
>
> [vrouter1]# *router add -net 195.11.14.0 netmask 255.255.255.0 eth0*
>
> [vrouter1]# ping 195.11.14.5   .....fail.-
>
> [vrouter1]# *vlist*
>
>    user              vhost                pid                   
> uptime        size                  interfaces
>
>    root              vrouter1            10795                
> 18:21           12312    eth0 @ tap, eth1 @ A
>
>  
>
> [root Pc2]#*vstart vrouter2 -eth0=A   --eth1=B   --new*
>
> [vrouter2]#*ifconfig eth0 195.11.14.11 up*
>
> [vrouter2]# *router add -net 195.11.14.0 netmask 255.255.255.0 eth0*
>
> [vrouter1]# *router add -net 195.11.14.0 netmask 255.255.255.0 eth1*
>
> [vrouter2]#ping 195.11.14.10 .....ok.-
>
> [vrouter2]#ping 195.11.14.9   .....ok.-
>
> [vrouter2]#ping 195.11.14.5   *.....fail.-*
>
>  
>
>  
>
> second:  
> __________________________________________________________________________
>
> ** 
>
> *Pc1(real host)*----------------------*Pc2(real host)*
>
>                                                                  
> |-----Vrouter1-------Vrouter2
>
>  
>
> - If start in first place, (#ifconfig..... only show a loopback), and 
> not,... ifconfig eth0,.. eth1. with ip number.-
>
>      
>
>  [root Pc2]#*vstart vrouter1 -eth0=tap,195.11.14.5,195.11.14.9 -eth1=A 
> -new*
>
>  
>
>  
>
>  , then, i can reach with ping Pc2--->Vrouter1
>
>                but, lost connectivity  
> Pc1(realhost)---------------->Pc2(realhost)  ,   and Pc2 -beyond- to 
> Vrouter1. (At  Vrouter1 it arrives).
>
>  
> ____________________________________________________________________________________________
>  
>  
> Please, if can send some configuration - that has proven -.
>  
>  
> Regards,
> Michael Angel
>  
>  
>  
>  
>  
>  
> ----- Original Message -----
> From: "Fabio Ricci" <ribio a tiscali.it <mailto:ribio a tiscali.it>>
> To: "Users of the Netkit Network Emulation System" 
> <netkit.users a did.dia.uniroma3.it 
> <mailto:netkit.users a did.dia.uniroma3.it>>
> Cc: <Netkit.users a did.dia.uniroma3.it 
> <mailto:Netkit.users a did.dia.uniroma3.it>>
> Sent: Thursday, January 05, 2006 1:23 PM
> Subject: Re: [Netkit.users] Interface problem.-
>
> > Hi Miguel,
> > you have to configure your routing tables,
> > please send the starting command for  virtual hosts, and the output of
> > command "ifconfig && route -n" on your host and virtual hosts
> >
> > bye
> > Fabio
> >
>
>------------------------------------------------------------------------
>
>_______________________________________________
>Netkit.users mailing list
>Netkit.users a list.dia.uniroma3.it
>http://list.dia.uniroma3.it/mailman/listinfo/netkit.users
>  
>
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: http://list.dia.uniroma3.it/mailman/private/netkit.users/attachments/20060110/663f1b62/attachment.htm


Maggiori informazioni sulla lista Netkit.users